Back to overview
Resolved
Updating core logic
Jun 24, 2026 at 8:43am UTC
–
Jun 24, 2026 at 10:43am UTC
Affected services
Cloud
API
Resolved
Jun 24, 2026 at 10:43am UTC
Maintenance ended
Affected services
Created
Jun 24, 2026 at 8:43am UTC
We are updating our billing infrastructure, this could lead to temporary billing issues
Affected services